Stories
Slash Boxes
Comments

SoylentNews is people

posted by martyb on Wednesday April 05 2017, @11:33AM   Printer-friendly
from the coding-skills-on-display dept.

LinuxGizmos has an interesting article on how an Intel Engineer fixed up Linux's DisplayPort compliance, and got the kernel patch moved upstream.

At ELC 2017, Intel's Manasi Navare described how she patched Linux 4.12 for true DisplayPort compliance, and offered tips on pushing patches upstream.

If you've ever hooked up a Linux computer to a DisplayPort monitor and encountered only a flickering or blank screen, we've got good news for you. A graphics kernel developer at Intel's Open Source Technology Center has solved the problem with a patch that will go into Linux Kernel 4.12. Manasi Navare's patch modifies Atomic Kernel Mode Setting (KMS) technology to gracefully drop down to a lower resolution to display the image.

"Someone had to fix this problem, so I said okay, I have the knowledge and I have the community to help me," said Navare at the recent Embedded Linux Conference.


Original Submission

 
This discussion has been archived. No new comments can be posted.
Display Options Threshold/Breakthrough Mark All as Read Mark All as Unread
The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
  • (Score: 1, Informative) by Anonymous Coward on Wednesday April 05 2017, @12:42PM (5 children)

    by Anonymous Coward on Wednesday April 05 2017, @12:42PM (#489095)

    I'm already using DisplayPort and it's on a >60hz 3440x1440 monitor. No issues.

    Starting Score:    0  points
    Moderation   +1  
       Informative=1, Total=1
    Extra 'Informative' Modifier   0  

    Total Score:   1  
  • (Score: 2) by bart9h on Wednesday April 05 2017, @01:39PM (4 children)

    by bart9h (767) on Wednesday April 05 2017, @01:39PM (#489133)

    I use DisplayPort too, with a 4K monitor @60Hz. The kernel is 3.16.0

    But I do have issues.

    Sometimes the monitor won't wake up after sleeping, like there's no signal. I have to turn it off and on again, and sometimes change virtual consoles, or even restart X.

    But what annoys me the most is that it freezes for some seconds in some situations. Like right after I login (it boots to the graphical login screen very fast, but takes a long time to load the desktop and unfreeze after I login), or after I connect or disconnect a HDMI cable to the TV.

    • (Score: 2) by JoeMerchant on Wednesday April 05 2017, @01:45PM (2 children)

      by JoeMerchant (3937) on Wednesday April 05 2017, @01:45PM (#489139)

      I have a 4K HDMI monitor connected to a Broadwell NUC running Windows 10, and it still can't get itself right most of the time.

      Watch a 2 hour movie on Netflix, at some point there will be at least 30 seconds of blank screen while the monitor and CPU are re-syncing with each other. MTBF on the HDMI sound interface seems to be around 12 hours, sometimes faster, sometimes slower, but eventually if you run it long enough, the sound will go away.

      It's down to drivers, I'm sure - but even Windows 10 doesn't seem to be getting their HDMI drivers completely right. I know 4K is "challenging" - but, please, we've been doing HDMI for over a decade, can we get it right already?

      --
      🌻🌻 [google.com]
      • (Score: 2) by Scruffy Beard 2 on Wednesday April 05 2017, @04:08PM (1 child)

        by Scruffy Beard 2 (6030) on Wednesday April 05 2017, @04:08PM (#489188)

        That is probably the DRM fucking you over. (You using The Edge browser to get 4K instead of 720P?)

        • (Score: 2) by JoeMerchant on Wednesday April 05 2017, @04:17PM

          by JoeMerchant (3937) on Wednesday April 05 2017, @04:17PM (#489194)

          Chrome, and from across the room I don't really care if it's 4K or 720p.

          Yeah, those could be DRM glitches on Netflix. When playing .mkv files back on Kodi, we get different glitches :(

          --
          🌻🌻 [google.com]
    • (Score: 2) by rleigh on Wednesday April 05 2017, @07:13PM

      by rleigh (4887) on Wednesday April 05 2017, @07:13PM (#489294) Homepage

      Does it turn back on if you unplug and replug the displayport cable? For me, this forces it to come back to life. I'll look forward to it being fixed properly, since it's something which I've been annoyed by for years!